DMVPN Phas1 Lab

Part of CCIE Lab Learning… testing DMVPN Phase1

Simple Lab Topology

For SP and other devices underlay reachability I used OSPF, and over GRE I used Eigrp.

Here is the config :

SP Config :

interface Ethernet0/0
ip address 192.168.0.1 255.255.255.252
ip ospf network point-to-point
!
interface Ethernet0/1
ip address 192.168.1.1 255.255.255.252
ip ospf network point-to-point
!
interface Ethernet0/2
ip address 192.168.2.1 255.255.255.252
ip ospf network point-to-point
!
!
router ospf 1
passive-interface default
no passive-interface Ethernet0/0
no passive-interface Ethernet0/1
no passive-interface Ethernet0/2
network 192.168.0.1 0.0.0.0 area 0
network 192.168.1.1 0.0.0.0 area 0
network 192.168.2.1 0.0.0.0 area 0
!

HUB

router ospf 1
network 192.168.2.2 0.0.0.0 area 0
!
router eigrp 100
no auto-summary
network 10.10.2.0 0.0.0.255
network 172.16.1.0 0.0.0.255
!
interface Loopback0
ip address 10.10.2.1 255.255.255.0
!
! mGRE tunnel
!
interface Tunnel0
ip address 172.16.1.1 255.255.255.0
no ip redirects
ip nhrp map multicast dynamic
ip nhrp network-id 100
no ip split-horizon eigrp 100
ip summary-address eigrp 100 10.10.0.0 255.0.0.0
tunnel source eth0/2
tunnel mode gre multipoint
tunnel key 100

SPOKE 1

router ospf 1
network 192.168.1.2 0.0.0.0 area 0
!
router eigrp 100
no auto-summary
network 172.16.1.0 0.0.0.255
network 10.10.1.0 0.0.0.255
eigrp stub connected
!
interface Loopback0
ip address 10.10.1.1 255.255.255.0
!
! GRE tunnel
!
interface Tunnel0
ip address 172.16.1.2 255.255.255.0
ip nhrp map 172.16.1.1 192.168.2.2
ip nhrp map multicast 192.168.2.2
ip nhrp nhs 172.16.1.1
ip nhrp network-id 100
ip nhrp holdtime 60
ip nhrp registration timeout 30
tunnel source eth0/1
tunnel destination 192.168.2.2
tunnel key 100

SPOKE 2

router ospf 1
network 192.168.0.2 0.0.0.0 area 0
!
router eigrp 100
no auto-summary
network 172.16.1.0 0.0.0.255
network 10.10.0.0 0.0.0.255
eigrp stub connected
!
interface Loopback0
ip address 10.10.0.1 255.255.255.0
!
! GRE tunnel
!
interface Tunnel0
ip address 172.16.1.3 255.255.255.0
ip nhrp map 172.16.1.1 192.168.2.2
ip nhrp map multicast 192.168.2.2
ip nhrp nhs 172.16.1.1
ip nhrp network-id 100
ip nhrp holdtime 60
ip nhrp registration timeout 30
tunnel source eth0/0
tunnel destination 192.168.2.2
tunnel key 100

Verifications :

HUB

SPOKE

EIGRP and Routes :

Reachability from Spoke2 :

Happy Labbing …!