VPLS simple test Lab

CSR 42 config

l2vpn
router-id 1.1.1.1
!
l2vpn vfi context ctx1
vpn id 20009
l2protocol forward cdp
autodiscovery bgp signaling bgp
ve id 123
rd 2000:9
!
bridge-domain 100
member GigabitEthernet2 service-instance 100
member vfi ctx1
!
!
cdp run
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 100.10.20.1 255.255.255.0
ip ospf 1 area 0
negotiation auto
cdp enable
no mop enabled
no mop sysid
!
interface GigabitEthernet2
no ip address
negotiation auto
cdp enable
no mop enabled
no mop sysid
service instance 100 ethernet
encapsulation untagged
l2protocol forward cdp
!
!
router ospf 1
router-id 1.1.1.1
passive-interface Loopback0
mpls ldp autoconfig
!
router bgp 12
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 update-source Loopback0
!
address-family l2vpn vpls
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community extended
neighbor 2.2.2.2 suppress-signaling-protocol ldp
exit-address-family
!

CSR43 config

l2vpn
router-id 1.1.1.1
!
l2vpn vfi context ctx1
vpn id 20009
l2protocol forward cdp
autodiscovery bgp signaling bgp
ve id 123
rd 2000:9
!
bridge-domain 100
member GigabitEthernet2 service-instance 100
member vfi ctx1
!
cdp run
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 100.10.20.1 255.255.255.0
ip ospf 1 area 0
negotiation auto
cdp enable
no mop enabled
no mop sysid
!
interface GigabitEthernet2
no ip address
negotiation auto
cdp enable
no mop enabled
no mop sysid
service instance 100 ethernet
encapsulation untagged
l2protocol forward cdp
!
!
router ospf 1
router-id 1.1.1.1
passive-interface Loopback0
mpls ldp autoconfig
!
router bgp 12
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 update-source Loopback0
!
address-family l2vpn vpls
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community extended
neighbor 2.2.2.2 suppress-signaling-protocol ldp
exit-address-family
!

R40 config

cdp run

!

interface Ethernet0/2
ip address 100.10.10.12 255.255.255.0
duplex auto
!

R42 config

cdp run

interface Ethernet0/2
ip address 100.10.10.13 255.255.255.0
duplex auto

Testing OSPF neigh

CSR42

CSR 43 :

MPLS LDP :

BGP

show ip bgp l2vpn vpls all summary

Good reference :

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/mp_l2_vpns/configuration/xe-16/mp-l2-vpns-xe-16-book/vpls-bgp-signaling-l2vpn-inter-as-option-a.html

happy Labbbing !!!!!!!