Dual ISP Failover using Route-map

Below Simple Lab Dual ISP failover testing using route-map – when the primary ISP link go down secondary ISP will take over automatically.

I have OSPF running between Google, ISP1, ISP2, GW1. GW2

Home Router having Static Route

I have basic configuration with NAT configuration on Home device :

track 100 ip sla 1 reachability
!
interface Ethernet0/0
ip address 192.168.100.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Ethernet0/1
ip address 192.168.10.2 255.255.255.252
ip nat outside
ip virtual-reassembly in
!
interface Ethernet0/2
ip address 192.168.20.2 255.255.255.252
ip nat outside
ip virtual-reassembly in
!
!
no ip http server
no ip http secure-server
ip nat inside source route-map ISP1 interface Ethernet0/1 overload
ip nat inside source route-map ISP2 interface Ethernet0/2 overload
ip route 0.0.0.0 0.0.0.0 192.168.10.1 track 100
ip route 0.0.0.0 0.0.0.0 192.168.20.1 100
!
ip sla 1
icmp-echo 8.8.8.8 source-interface Ethernet0/1
frequency 5
ip sla schedule 1 life forever start-time now
!
route-map ISP2 permit 10
match ip address 110
match interface Ethernet0/2
!
route-map ISP1 permit 10
match ip address 110
match interface Ethernet0/1
!
!
access-list 110 permit ip 192.168.100.0 0.0.0.255 any
!

PC device having IP address 192.168.100.2 gateway 192.168.100.1

basic reachability testing:

From PC :

Home Router – Routing and NAT Translation

Route going via ISP 1 192.168.10.1

The NAT Translation going via ISP 1

Lets check IP sla summary :

Lets Failover and test it :

IP SLA timeout after 5 seconds :

you can see the Logs track gone down

Routing changed to ISP2 :

PC still can ping :

NAT translation using ISP2

you can also check track :

When the ISP1 Link come up – we can observe below Logs and information on the Router :

I have Rough Configuration File all in one File as below – if you like to use

Happy labbbing………………!