Basic DSL connection PPPoE

ISP —-ISP Router(your Cisco router—Lan Switch

Example :

Interface Gig 0/0 – connected to ISP
interface Gig 0/1 – LAN to your switchto switch

Router config

!
hostname MYRouter
!
!
ip dhcp excluded-address 192.168.10.1 192.168.10.20
!
ip dhcp pool LANPOOL
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 192.168.10.1 (this can be 8.8.8.8)
!
multilink bundle-name authenticated
!
interface GigabitEthernet0/0
no ip address
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/0.80
encapsulation dot1Q 80
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface GigabitEthernet0/1
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
no cdp enable
!
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname xxxxxx
ppp chap password 0 xxxxxx
ppp pap sent-username xxxxx password 0 xxxxxx
no cdp enable
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 20 interface dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
!
access-list 20 permit 192.168.10.0 0.0.0.255
!