Enhanced vPC Testing

Enhanced vPC Testing

I have been working since long in DC Environment with Nexus Switches along with UCS, Never got a chance to setup a Lab and explain some config.

some of Live Environment, we are not allowed to do some test.

Finally Eve-NG is a good Gui for DC lab testing, and now it support to LACP on N9K and Server Side.

 

Cisco has a good documentation to understand vPC

https://www.cisco.com/c/en/us/products/collateral/switches/nexus-5000-series-switches/design_guide_c07-625857.html#_Toc271759485

 

EVE-NG have nice platform to test some features – can be download  Lab below Link :

_Exports_unetlab_export-20180813-202843

vPC Config on N7K1 and N7K2


 

Nexus 1 & 2 with VPC Nexus   – CORE
Nexus 1
=======
config t
!
switchname N7K1
!
cfs eth distribute
feature udld
feature interface-vlan
feature lacp
feature vpc
feature lldp
feature vtp
feature bfd
!
ip domain-lookup
system default switchport shutdown
errdisable recovery cause link-flap
errdisable recovery cause udld
errdisable recovery cause bpduguard
errdisable recovery cause loopback
policy-map type control-plane copp-system-policy-customized
!
vlan 1,10,20,30,40,50,60,100
!
vrf context management
vrf context vpckeepalive
  description vpc-keep-alive
vpc domain 1
  peer-switch
  role priority 2000
  peer-keepalive destination 1.1.1.2 source 1.1.1.1 vrf vpckeepalive
  delay restore 120
  auto-recovery reload-delay 300
!
interface Vlan1
!
interface port-channel1
  description *** vPC Peer-Link ***
  switchport mode trunk
  switchport trunk allowed vlan 10-50,100
  spanning-tree port type network
  vpc peer-link
!
interface Ethernet1/1
  switchport mode trunk
  switchport trunk allowed vlan 10-50,100
  channel-group 1 mode active
  no shutdown
!
interface Ethernet1/2
  switchport mode trunk
  switchport trunk allowed vlan 10-50,100
  channel-group 1 mode active
  no shutdown
!
interface Ethernet1/13
  description [(vPC KeepAlive link between Distribution 5K switches)]
  no switchport
  vrf member vpckeepalive
  ip address 1.1.1.1/30
  no shutdown
!
interface mgmt0
  vrf member management
Nexus 2
==========
config t
!
switchname N7K2
!
cfs eth distribute
feature udld
feature interface-vlan
feature lacp
feature vpc
feature vtp
!
ip domain-lookup
system default switchport shutdown
errdisable recovery cause link-flap
errdisable recovery cause udld
errdisable recovery cause bpduguard
errdisable recovery cause loopback
!
vlan 1,10,20,30,40,50,60,100
!
vrf context management
vrf context vpckeepalive
  description vpc-keepalive
vpc domain 1
  peer-switch
  role priority 2000
  peer-keepalive destination 1.1.1.1 source 1.1.1.2 vrf vpckeepalive
  delay restore 120
  auto-recovery reload-delay 300
!
interface Vlan1
!
interface port-channel1
  description *** vPC Peer-Link ***
  switchport mode trunk
  switchport trunk allowed vlan 10-50,100
  spanning-tree port type network
  vpc peer-link
!
interface Ethernet1/1
  switchport mode trunk
  switchport trunk allowed vlan 10-50,100
  channel-group 1 mode active
  no shutdown
!
interface Ethernet1/2
  switchport mode trunk
  switchport trunk allowed vlan 10-50,100
  channel-group 1 mode active
  no shutdown
!
interface Ethernet1/13
  description [(vPC KeepAlive link between Distribution 5K switches)]
  no switchport
  vrf member vpckeepalive
  ip address 1.1.1.2/30
  no shutdown
!
interface mgmt0
  vrf member management
Results of vPC
==================
N7K1# show vpc
Legend:
                (*) – local vPC is down, forwarding via vPC peer-link
vPC domain id                     : 1
Peer status                       : peer adjacency formed ok
vPC keep-alive status             : peer is alive
Configuration consistency status  : success
Per-vlan consistency status       : success
Type-2 consistency status         : success
vPC role                          : primary, operational secondary
Number of vPCs configured         : 1
Peer Gateway                      : Disabled
Dual-active excluded VLANs        : –
Graceful Consistency Check        : Enabled
Auto-recovery status              : Enabled, timer is off.(timeout = 300s)
Delay-restore status              : Timer is off.(timeout = 120s)
Delay-restore SVI status          : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router    : Disabled
vPC Peer-link status
———————————————————————
id    Port   Status Active vlans
—    —-   —— ————————————————-
1     Po1    up     10,20,30,40,50,100
vPC status
—————————————————————————-
Id    Port          Status Consistency Reason                Active vlans
—    ————  —— ———– ——                —————
11    Po11          up     success     success               10,20,30,40,50
                                                             ,100
Please check “show vpc consistency-parameters vpc <vpc-num>” for the
consistency reason of down vpc and for type-2 consistency reasons for
any vpc.
N7K2# show vp
Legend:
                (*) – local vPC is down, forwarding via vPC peer-link
vPC domain id                     : 1
Peer status                       : peer adjacency formed ok
vPC keep-alive status             : peer is alive
Configuration consistency status  : success
Per-vlan consistency status       : success
Type-2 consistency status         : success
vPC role                          : secondary, operational primary
Number of vPCs configured         : 1
Peer Gateway                      : Disabled
Dual-active excluded VLANs        : –
Graceful Consistency Check        : Enabled
Auto-recovery status              : Enabled, timer is off.(timeout = 300s)
Delay-restore status              : Timer is off.(timeout = 120s)
Delay-restore SVI status          : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router    : Disabled
vPC Peer-link status
———————————————————————
id    Port   Status Active vlans
—    —-   —— ————————————————-
1     Po1    up     10,20,30,40,50,100
vPC status
—————————————————————————-
Id    Port          Status Consistency Reason                Active vlans
—    ————  —— ———– ——                —————
11    Po11          up     success     success               10,20,30,40,50
                                                             ,100
Please check “show vpc consistency-parameters vpc <vpc-num>” for the
consistency reason of down vpc and for type-2 consistency reasons for
any vpc.
Configuring on Access Side
============================
Same config applies with  Access Switch, only Domain ID changes.
Back to back vPC
================
N7K1 to Cust 5K 1 and 5K2
==========================
N7k1
interface port-channel11
  description *** vPC11 to Cust 5K1 ***
  switchport mode trunk
  switchport trunk allowed vlan 10-50,100
  vpc 11
interface Ethernet1/3-6
  switchport mode trunk
  switchport trunk allowed vlan 10-50,100
  channel-group 11 mode active
   no shutdown
N7k2
interface port-channel11
  description *** vPC11 to Cust 5K1  ***
  switchport mode trunk
  switchport trunk allowed vlan 10-50,100
  vpc 11
interface Ethernet1/3-6
  switchport mode trunk
  switchport trunk allowed vlan 10-50,100
  channel-group 11 mode active
   no shutdown
Cust 5K1 and 5K2
=========
interface port-channel22
  description *** vPC11 to N7K1-2 ***
  switchport mode trunk
  switchport trunk allowed vlan 10-50,100
  vpc 22
interface Ethernet1/3-6
  switchport mode trunk
  switchport trunk allowed vlan 10-50,100
  channel-group 22 mode active
   no shutdown
Cust 5K2
=========
interface port-channel22
  description *** vPC22 to N7K1-2 ***
  switchport mode trunk
  switchport trunk allowed vlan 10-50,100
  no shutdown
  vpc22
interface Ethernet1/3-6
  switchport mode trunk
  switchport trunk allowed vlan 10-50,100
  channel-group 22 mode active
   no shutdown
vPC results :
=============
CUS5K1# show vpc
Legend:
                (*) – local vPC is down, forwarding via vPC peer-link
vPC domain id                     : 2
Peer status                       : peer adjacency formed ok
vPC keep-alive status             : peer is alive
Configuration consistency status  : success
Per-vlan consistency status       : success
Type-2 consistency status         : success
vPC role                          : primary
Number of vPCs configured         : 1
Peer Gateway                      : Disabled
Dual-active excluded VLANs        : –
Graceful Consistency Check        : Enabled
Auto-recovery status              : Enabled, timer is off.(timeout = 300s)
Delay-restore status              : Timer is off.(timeout = 120s)
Delay-restore SVI status          : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router    : Disabled
vPC Peer-link status
———————————————————————
id    Port   Status Active vlans
—    —-   —— ————————————————-
1     Po1    up     10,20,30,40,50,100
vPC status
—————————————————————————-
Id    Port          Status Consistency Reason                Active vlans
—    ————  —— ———– ——                —————
22    Po22          up     success     success               10,20,30,40,50
                                                             ,100
Please check “show vpc consistency-parameters vpc <vpc-num>” for the
consistency reason of down vpc and for type-2 consistency reasons for
any vpc.
CUS5K2# show vpc
Legend:
                (*) – local vPC is down, forwarding via vPC peer-link
vPC domain id                     : 2
Peer status                       : peer adjacency formed ok
vPC keep-alive status             : peer is alive
Configuration consistency status  : success
Per-vlan consistency status       : success
Type-2 consistency status         : success
vPC role                          : secondary
Number of vPCs configured         : 1
Peer Gateway                      : Disabled
Dual-active excluded VLANs        : –
Graceful Consistency Check        : Enabled
Auto-recovery status              : Enabled, timer is off.(timeout = 300s)
Delay-restore status              : Timer is off.(timeout = 120s)
Delay-restore SVI status          : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router    : Disabled
vPC Peer-link status
———————————————————————
id    Port   Status Active vlans
—    —-   —— ————————————————-
1     Po1    up     10,20,30,40,50,100
vPC status
—————————————————————————-
Id    Port          Status Consistency Reason                Active vlans
—    ————  —— ———– ——                —————
22    Po22          up     success     success               10,20,30,40,50
                                                             ,100
Please check “show vpc consistency-parameters vpc <vpc-num>” for the
consistency reason of down vpc and for type-2 consistency reasons for
any vpc.
Access to Server
===============
Cust 5K1
=========
interface port-channel13
  description *** Po13 to Server  ***
  switchport mode trunk
  switchport trunk allowed vlan 100
  no shutdown
interface Ethernet1/9
  switchport mode trunk
  channel-group 13 force mode active
   no shutdown
Cust 5K2
=========
interface port-channel13
  description *** Po13 to Server  ***
  switchport mode trunk
  switchport trunk allowed vlan 100
  no shutdown
interface Ethernet1/9
  switchport mode trunk
  channel-group 13 force mode active
   no shutdown

Configuring Windows 2016 for LACP

 

 

 

 

 

 

 

 

 

 

Windows Server with 2NIC, Each Side Port-channel with VPC Active Active Traffic  :

N5K1
interface port-channel14
  switchport access vlan 100
  vpc 14
interface Ethernet1/10-11
  switchport access vlan 100
  channel-group 14 mode active
  no shutdown
N5K2
interface port-channel14
  switchport access vlan 100
  vpc 14
interface Ethernet1/10-11
  switchport access vlan 100
  channel-group 14 mode active
  no shutdown
Happy Labbbing !